lkml.org 
[lkml]   [2013]   [Sep]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/3] PM / OPP: rename to dev_pm_opp * equivalents
Date
Hi,

Based on [1], Randy rightly pointed out that OPP functions and data
structures could be a bit specific to Power management.

So, the following series is based on v3.12-rc1 tag.

If folks like it broken in a different way, I am open to suggestions.

Nishanth Menon (3):
PM / OPP: rename functions to dev_pm_opp*
PM / OPP: rename data structures to dev_pm equivalents
PM / OPP: rename header to linux/pm_opp.h

Documentation/power/opp.txt | 108 ++++++++++++------------
arch/arm/mach-imx/mach-imx6q.c | 4 +-
arch/arm/mach-omap2/board-omap3beagle.c | 10 +--
arch/arm/mach-omap2/omap-pm.h | 2 +-
arch/arm/mach-omap2/opp.c | 6 +-
arch/arm/mach-omap2/pm.c | 8 +-
drivers/base/power/opp.c | 115 ++++++++++++-------------
drivers/cpufreq/arm_big_little.c | 8 +-
drivers/cpufreq/arm_big_little_dt.c | 2 +-
drivers/cpufreq/cpufreq-cpu0.c | 24 +++---
drivers/cpufreq/exynos5440-cpufreq.c | 17 ++--
drivers/cpufreq/imx6q-cpufreq.c | 26 +++---
drivers/cpufreq/omap-cpufreq.c | 12 +--
drivers/devfreq/devfreq.c | 25 +++---
drivers/devfreq/exynos/exynos4_bus.c | 29 +++----
drivers/devfreq/exynos/exynos5_bus.c | 28 +++----
include/linux/devfreq.h | 6 +-
include/linux/opp.h | 134 -----------------------------
include/linux/pm_opp.h | 139 +++++++++++++++++++++++++++++++
19 files changed, 357 insertions(+), 346 deletions(-)
delete mode 100644 include/linux/opp.h
create mode 100644 include/linux/pm_opp.h

--
1.7.9.5



\
 
 \ /
  Last update: 2013-09-19 23:21    [W:0.055 / U:0.384 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site