[lkml]   [2013]   [Sep]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/3] PM / OPP: rename functions to dev_pm_opp*
On 12:44-20130920, Viresh Kumar wrote:
> On 20 September 2013 02:33, Nishanth Menon <> wrote:
> > opp_get_opp_count
> > opp_find_freq_exact
> > opp_init_cpufreq_table
> > opp_free_cpufreq_table
> The only problem I see is that routines names for few of them are getting
> really long now.. Otherwise not much I could find...
I am open to suggestions if any one feels we can improve this better.

> Though you had following changes, which you could have avoided in this
> hard to review patchset:
> diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c
> new_opp = [-kzalloc(sizeof(struct
> opp),-]{+kzalloc(sizeof(*new_opp),+} GFP_KERNEL);
> new_opp = [-kmalloc(sizeof(struct
> opp),-]{+kmalloc(sizeof(*new_opp),+} GFP_KERNEL);
> It is almost impossible to catch these with naked eyes for such long
> patches.. I took help of --word-diff though :)
I believe that change was from Patch #2[1]
yes, you are right, I had squashed this patch in to squelch checkpatch
CHECK: Prefer kzalloc(sizeof(*new_opp)...) over kzalloc(sizeof(struct
#177: FILE: drivers/base/power/opp.c:406:
+ new_opp = kzalloc(sizeof(struct dev_pm_opp), GFP_KERNEL);

CHECK: Prefer kmalloc(sizeof(*new_opp)...) over kmalloc(sizeof(struct
#191: FILE: drivers/base/power/opp.c:495:
+ new_opp = kmalloc(sizeof(struct dev_pm_opp), GFP_KERNEL);

I had added a comment:
" Minor checkpatch warning fixes as a result of this change was fixed as

Would you suggest I split the change off to a separate patch or improve
the comment a little more?
> If no one else sees these as problems then feel free to add my:
> Acked-by: Viresh Kumar <>

Nishanth Menon

 \ /
  Last update: 2013-09-20 15:01    [W:0.056 / U:7.224 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site