lkml.org 
[lkml]   [2012]   [Sep]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 18/57] power: Add sysfs interfaces for capacity
On 12-09-27 01:08 AM, Anton Vorontsov wrote:
> On Tue, Sep 25, 2012 at 10:12:15AM -0600, mathieu.poirier@linaro.org wrote:
>> From: Daniel WILLERUD <daniel.willerud@stericsson.com>
>>
>> Switchable depending on whether capacity scaling is enabled
>>
>> Signed-off-by: Marcus Cooper <marcus.xm.cooper@stericsson.com>
>> Signed-off-by: Daniel WILLERUD <daniel.willerud@stericsson.com>
>> Signed-off-by: Mathieu Poirier <mathieu.poirier@linaro.org>
>> Reviewed-by: Jonas ABERG <jonas.aberg@stericsson.com>
>> ---
>> drivers/power/ab8500_fg.c | 57 ++++++++++++++++++++++++++++++++++++++++++++-
>> 1 files changed, 56 insertions(+), 1 deletions(-)
>>
>> diff --git a/drivers/power/ab8500_fg.c b/drivers/power/ab8500_fg.c
>> index 8507254..46010ec 100644
>> --- a/drivers/power/ab8500_fg.c
>> +++ b/drivers/power/ab8500_fg.c
>> @@ -266,7 +266,6 @@ static enum power_supply_property ab8500_fg_props[] = {
>> POWER_SUPPLY_PROP_CHARGE_FULL_DESIGN,
>> POWER_SUPPLY_PROP_CHARGE_FULL,
>> POWER_SUPPLY_PROP_CHARGE_NOW,
>> - POWER_SUPPLY_PROP_CAPACITY,
> [...]
>> +static struct device_attribute ab8500_fg_sysfs_psy_attrs[] = {
>> + __ATTR(capacity, S_IRUGO, ab8500_show_capacity, NULL),
>> +};
>
> I don't understand the rationale behind this patch. Why remove normal
> power supply property, and make your own with the same name? Something
> isn't right...

The similarity in the naming convention it a coincidence here. In one
case it's a enum and the other sysfs attribute. Could you expand on
your suspicions ?

>



\
 
 \ /
  Last update: 2012-09-28 21:01    [W:0.736 / U:0.264 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site