[lkml]   [2000]   [Feb]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: 2.3.43 alpha broken with >2g of ram
    Richard Henderson wrote:

    > On Thu, Feb 10, 2000 at 11:54:44PM +0100, Andrea Arcangeli wrote:
    > > Could you explain me how can 2.3.43 work? How do you do PCI-DMA over 2giga
    > > of ram on the page cache or on the buffer cache or in whatever else DMA
    > > with pci driver that is not yet using the new pci mmu code like some
    > > network driver is just doing?
    > If the machine uses drivers that have not been converted, it
    > doesn't work at all. I disabled that code specifically so that
    > Pete Rival *could* try a machine with all drivers converted.

    I did try it, and sent a failure note to axp-list, yourself, and Jay. Only Jay
    responded, but it looks like something was busted in the driver as far as we
    can tell. Could very well have been that only Jay got the message - mail out
    of Compaq was flaky at ZK that day, IIRC.

    JSYK, it blew up when trying to scan the QLogic 1040B adapters in the system
    for drives, complaining of SCSI command timeouts. This is both with the driver
    in 2.3.42 and the one that was in the vger CVS tree at around the time you sent
    out your -2 patch. If someone can point me to a qlogicisp driver that they
    believe works correctly, I'll give them an answer if I get it before the end of
    the day today. (Have to give up the system for other testing for a week at the
    end of the day.) Anyone?

    - Pete

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:56    [W:0.023 / U:21.632 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site