lkml.org 
[lkml]   [1996]   [May]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[104] Linux kernels will not uncompress on a PC/104 386 board. why??
I'm having difficulty getting an Intel 386SL-25Mhz based platform to
boot a linux kernel and was wondering if some booting guru around here
would be able to help me solve the problem. Since I too believe linux
should take over and rule the world I think it would be good if I
could get it running on this platform too...

The hardware is actually a PC/104 computer which consists of a single
circuit board containing all the functions of a PC. From DOS's point
of view this board seems to be 100% IBM compatible.

The actual hardware is a Megatel Brand PC/II+ model PC/104 embedded
computer consisting of the following major chips:
CPU: Intel i386SL KU80386SLB1C-25
Floppy controller: SMC FDC37C65CLJ P
SCSI: unknown manufacturer (NEC?) DP5380V S9418AD
Video VGA: CHIPS F65530 A
Ethernet: Intel FA82595
Serial/parallel I/O: Intel KU82360SL

there are some other chips but I am unable to identify their function
or they don't seem really relevant at this time.

When this board is hooked up to an XT keyboard, a monitor, a floppy
drive, a scsi hard disk and a suitable power supply it functions just
like a PC and I get the following bios messages at the beginning of a
boot sequence (before any boot sectors are picked up/loaded/executed
or what ever happens with boot sectors)...

+------------------------------------+
| (c) Copyright 1984-1993 |
| Megatel Computer Corp. |
+------------------------------------+
| Equipment: |
| |
| System Devices ok |
| Video Cards 1 |
| RAM Memory 3328+640 Kb |
| Serial Ports 2 |
| Printer Ports 1 |
| Diskette Adapter ok |
| Diskette Drives 1 |
| Auxiliary Ports 1 |
| Option ROMS 3 |
+------------------------------------+
TrueFFS-BIOS -- Version 3.11B5
Copyright (c) M-Systems 1992, 1993
TSROM: SCSI BIOS, Version 2.14
Megatel Socket Services 3.1B51
PC/II+ Flash Disk @D000h, 2048 KBytes.
SCSI ID: 0 Device: MAXTOR 7290-SCSI Drive C:

So those are the diagnostics I get before booting anything. I can
boot DOS fine from either the floppy disk, the scsi disk (once it's
been loaded there) and also from the 2Meg FLASH disk without problems.
So DOS seems to treat this machine exactly as any other IBM/PC without
any difficulties or complaints. (I mean difficulties other than being
stuck with DOS ;-)

I understand that the flash disk only looks and acts like drive D: to
DOS because BIOS routines are loaded and that these aren't going to
work for linux because it ignores BIOS or something like that. I'm not
worried about the flash disk booting yet until I can get it to boot
linux from the hard disk. I'll work on device drivers for the flash
disk later...

anyways. you gurus will probably be able to nail down my problem
pretty quick since it is 100% repeatable and happens at the very start
of the boot process...

For the following information I have used kernel versions 1.2.13(a.out),
1.3.57(ELF), 1.3.95(ELF), 1.3.97(ELF) all have been configured with:
minimal set of drivers:
Kernel Floating Point emulation IS enabled
Memory IS limited to the low 16M (this board only has 4M or so)
Floppy driver
no IDE drivers
no SCSI drivers (when I can get something to boot I'll add this so I
can access my disk drive.
no ethernet drivers
no networking
nothing else.

I created all the kernels using
make mrproper
make config
make dep
make clean
make zImage
dd if=/usr/src/linux/arch/i386/boot/zImage of=/dev/fd0

all of the kernels I have tried can SUCCESSFULLY boot my NORMAL desktop
machine and when I boot my desktop with the floppy disk I get the
following diagnostics...

Loading................................
Uncompressing Linux...done.
Now booting the kernel
Console: 16 point font, 400 scans
Console: colour VGA+ 80x25, 1 virtual console (max 63)

and it continues on in a normal fashion panicking when attempting to
mount root (which is no surprise since I have no hard disk drivers
enabled).

HOWEVER when I try to use this same disk to boot the Megatel 386SL
board that I want to use I only get the following...

Loading................................

(I do get a carriage return after that line so that the cursor winds
up just below the 'L' in Loading and it just sits there) I do not get
the "Uncompressing kernel..." portion at all that one would normally
get on that line and the computer is just hung.

I tried looking through the bootsect code and files but I'm not very
good with this low level assembly and I'm not familiar enough with
boot procedures and caveats to make heads or tails out of what is
going on or wrong.

Does anybody have any suggestions as to what may be preventing this
board from booting (If I can get past the uncompression stage maybe
everything else will work? or Any ideas on what I can do to solve the
problem? or What can I do to help troubleshoot the problem further?
let me know, I'll try anything at this point 'cause I'm sh*t out o'
ideas.

Thanks for all your help and I apologize for the length of this
message but I wanted to be as specific as possible and include as much
relevant information as I could.

- Jeff Wiegley



\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.038 / U:1.572 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site