lkml.org 
[lkml]   [2010]   [Oct]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 11/18] fs: Introduce per-bucket inode hash locks
On Fri, Oct 08, 2010 at 04:21:25PM +1100, Dave Chinner wrote:
> - if (hlist_unhashed(&inode->i_hash))
> + if (hlist_bl_unhashed(&inode->i_hash))

That, OTOH, begs for (inlined) helper with more readable name.

> HFS_I(inode)->rsrc_inode = dir;
> HFS_I(dir)->rsrc_inode = inode;
> igrab(dir);
> - hlist_add_head(&inode->i_hash, &HFS_SB(dir->i_sb)->rsrc_inodes);
> + hlist_bl_add_head(&inode->i_hash, &HFS_SB(dir->i_sb)->rsrc_inodes);
> mark_inode_dirty(inode);

Lovely. What protects that list? Same question for hfsplus...


\
 
 \ /
  Last update: 2010-10-08 11:51    [W:0.470 / U:0.340 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site