lkml.org 
[lkml]   [2021]   [Jul]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH -tip v8 10/13] x86/kprobes: Push a fake return address at kretprobe_trampoline

* Masami Hiramatsu <mhiramat@kernel.org> wrote:

> + /* Replace fake return address with real one. */
> + *frame_pointer = kretprobe_trampoline_handler(regs, frame_pointer);
> + /*
> + * Move flags to sp so that kretprobe_trapmoline can return
> + * right after popf.

What is a trapmoline?

Also, in the x86 code we capitalize register and instruction names so that
they are more distinctive and easier to read in the flow of English text.

Thanks,

Ingo

\
 
 \ /
  Last update: 2021-07-05 10:18    [W:0.250 / U:0.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site