lkml.org 
[lkml]   [2018]   [Dec]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] blk_types.h: Use REQ_OP_WRITE in op_is_write
Date
Instead of just using plain '1', as it improves readability.

Signed-off-by: Marcos Paulo de Souza <marcos.souza.org@gmail.com>
---
include/linux/blk_types.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/linux/blk_types.h b/include/linux/blk_types.h
index 1dcf652ba0aa..905c666a0101 100644
--- a/include/linux/blk_types.h
+++ b/include/linux/blk_types.h
@@ -377,7 +377,7 @@ static inline void bio_set_op_attrs(struct bio *bio, unsigned op,

static inline bool op_is_write(unsigned int op)
{
- return (op & 1);
+ return (op & REQ_OP_WRITE);
}

/*
--
2.16.4
\
 
 \ /
  Last update: 2018-12-22 18:21    [W:0.075 / U:0.144 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site