[lkml]   [2014]   [Apr]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH 0/5] Use an alternative to _PAGE_PROTNONE for _PAGE_NUMA v2
On Tue, Apr 08, 2014 at 10:01:39AM -0700, Linus Torvalds wrote:
> On Tue, Apr 8, 2014 at 9:46 AM, Mel Gorman <> wrote:
> >
> > If you are ok with leaving _PAGE_NUMA as _PAGE_PROTNONE
> Dammit, this feature is f*cking brain-damaged.
> My complaint has been (and continues to be):
> - either it is 100% the same as PROTNONE, in which case thjat
> _PAGE_NUMA bit had better go away, and you just use the protnone
> helpers!

In which case we'd still use VMAs to distinguish between PROTNONE faults
and NUMA hinting faults. We may still need some special casing. It's plan
b but not my preferred solution at this time.

> - if it's not the same as PROTNONE, then it damn well needs a different bit.

With this series applied _PAGE_NUMA != _PAGE_PROTNONE.

> You can't have it both ways. You guys tried. The Xen case shows that
> trying to distinguish the two DOES NOT WORK. But even apart from the
> Xen case, it was just a confusing hell.

Which is why I responded with a series that used a different bit instead
of more discussions that would reach the same conclusion.

> Like Yoda said: "Either they are the same or they are not. There is no 'try'".
> So pick one solution. Don't try to pick the mixed-up half-way case
> that is a disaster and makes no sense.

I picked a solution. The posted series uses a different bit.

Mel Gorman

 \ /
  Last update: 2014-04-08 21:21    [W:0.090 / U:4.308 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site