[lkml]   [2014]   [Apr]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH 0/5] Use an alternative to _PAGE_PROTNONE for _PAGE_NUMA v2
On Tue, Apr 8, 2014 at 9:46 AM, Mel Gorman <> wrote:
> If you are ok with leaving _PAGE_NUMA as _PAGE_PROTNONE


Dammit, this feature is f*cking brain-damaged.

My complaint has been (and continues to be):

- either it is 100% the same as PROTNONE, in which case thjat
_PAGE_NUMA bit had better go away, and you just use the protnone

- if it's not the same as PROTNONE, then it damn well needs a different bit.

You can't have it both ways. You guys tried. The Xen case shows that
trying to distinguish the two DOES NOT WORK. But even apart from the
Xen case, it was just a confusing hell.

Like Yoda said: "Either they are the same or they are not. There is no 'try'".

So pick one solution. Don't try to pick the mixed-up half-way case
that is a disaster and makes no sense.


 \ /
  Last update: 2014-04-08 19:21    [W:0.105 / U:0.320 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site