lkml.org 
[lkml]   [2011]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectdrivers/ata/sata_dwc_460ex.c: Do we still need "struct of_device_id sata_dwc_match"

Hello,

sata_dwc is also present on SPEAr SoC from ST, so i am removing dependency of this
driver from 460ex and renaming it to sata_dwc.c.

While doing that, i saw following:

static const struct of_device_id sata_dwc_match[] = {
{ .compatible = "amcc,sata-460ex", },
{}
};
MODULE_DEVICE_TABLE(of, sata_dwc_match);


I don't know if this is still useful or not with platform_device, as it was with
of_platform_*.

Should i remove it completely? or should i just rewrite following as:

static const struct of_device_id sata_dwc_match[] = {
{ .compatible = "amcc,sata_dwc", },
{}
};
MODULE_DEVICE_TABLE(of, sata_dwc_match);

For this i will also update: arch/powerpc/boot/dts/canyonlands.dts

SATA0: sata@bffd1000 {
compatible = "amcc,sata-460ex";
reg = <4 0xbffd1000 0x800 4 0xbffd0800 0x400>;
interrupt-parent = <&UIC3>;
interrupts = <0x0 0x4 /* SATA */
0x5 0x4>; /* AHBDMA */
};

Thanks for your replies.

--
viresh


\
 
 \ /
  Last update: 2011-06-07 12:57    [W:0.274 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site