lkml.org 
[lkml]   [2011]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: drivers/ata/sata_dwc_460ex.c: Do we still need "struct of_device_id sata_dwc_match"
On Tue, Jun 07, 2011 at 04:23:07PM +0530, viresh kumar wrote:
>
> Hello,
>
> sata_dwc is also present on SPEAr SoC from ST, so i am removing dependency of this
> driver from 460ex and renaming it to sata_dwc.c.
>
> While doing that, i saw following:
>
> static const struct of_device_id sata_dwc_match[] = {
> { .compatible = "amcc,sata-460ex", },
> {}
> };
> MODULE_DEVICE_TABLE(of, sata_dwc_match);
>
>
> I don't know if this is still useful or not with platform_device, as it was with
> of_platform_*.
>
> Should i remove it completely? or should i just rewrite following as:
>
> static const struct of_device_id sata_dwc_match[] = {
> { .compatible = "amcc,sata_dwc", },
> {}
> };
> MODULE_DEVICE_TABLE(of, sata_dwc_match);

No, don't remove it and don't remove the "amcc,sata-460ex" string.
The compatible property is intended to identify the exact hardware,
and removing existing strings will break deployed boards. However, it
is fine to add new strings to the match table.

>
> For this i will also update: arch/powerpc/boot/dts/canyonlands.dts
>
> SATA0: sata@bffd1000 {
> compatible = "amcc,sata-460ex";
> reg = <4 0xbffd1000 0x800 4 0xbffd0800 0x400>;
> interrupt-parent = <&UIC3>;
> interrupts = <0x0 0x4 /* SATA */
> 0x5 0x4>; /* AHBDMA */
> };
>
> Thanks for your replies.
>
> --
> viresh


\
 
 \ /
  Last update: 2011-06-07 17:07    [W:0.059 / U:0.368 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site