lkml.org 
[lkml]   [2010]   [Dec]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [ath9k-devel] [PATCH wireless-next] ath: Rename ath_print to ath_debug
From
Date
On Tue, 2010-11-30 at 23:56 -0800, Luis R. Rodriguez wrote:
> On Tue, Nov 30, 2010 at 12:19 PM, Joe Perches <joe@perches.com> wrote:
> > Poor function naming is just that.
> > It reduces readability and the uses are counter expectation.
> The name is perfect, we use it to print anything, even non-debugging stuff.

'fraid not.

ath/debug.h

#ifdef CONFIG_ATH_DEBUG
void ath_print(struct ath_common *common, int dbg_mask, const char *fmt, ...)
__attribute__ ((format (printf, 3, 4)));
#else
static inline void __attribute__ ((format (printf, 3, 4)))
ath_print(struct ath_common *common, int dbg_mask, const char *fmt, ...)
{
}
#endif /* CONFIG_ATH_DEBUG */



\
 
 \ /
  Last update: 2010-12-01 15:31    [from the cache]
©2003-2011 Jasper Spaans