lkml.org 
[lkml]   [2010]   [Dec]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [ath9k-devel] [PATCH wireless-next] ath: Rename ath_print to ath_debug
On Tue, Nov 30, 2010 at 11:56 PM, Luis R. Rodriguez <mcgrof@gmail.com> wrote:
> On Tue, Nov 30, 2010 at 12:19 PM, Joe Perches <joe@perches.com> wrote:
>> On Tue, 2010-11-30 at 03:43 +0100, Felix Fietkau wrote:
>>> On 2010-11-30 2:39 AM, Joe Perches wrote:
>>> > I gauge my willingness to spend time on subsystems on
>>> > the maintainers willingness to merge things that improve
>>> > readability and correctness.
>>> I'm not trying to discourage you from spending time on improving this
>>> code, just doubting the usefulness of such simple function renames.
>>
>> Poor function naming is just that.
>> It reduces readability and the uses are counter expectation.
>
> The name is perfect, we use it to print anything, even non-debugging stuff.

If you are writing trivial patches please be ready to accept trivial
NACKs for them as well. IMHO its best if the large diffstat trivial
patches had more purpose than just scratch a small tiny itch.

Luis


\
 
 \ /
  Last update: 2010-12-01 09:01    [from the cache]
©2003-2011 Jasper Spaans