lkml.org 
[lkml]   [2008]   [Aug]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: tty: ctrl-c not always echoed, especially under load
On Wed, 06 Aug 2008 14:17:29 -0600
Joe Peterson <joe@skyrush.com> wrote:

> Alan Cox wrote:
> > If the output buffer is full then echoed characters/^C etc will vanish the
> > way n_tty implements its buffering internally. It's always worked that
> > way.
>
> One more observation:
>
> In Linux, try this:
>
> # cat > foo
> hi^Sthere^Q
> ^D
>
> (in other words, during the cat into "foo", type "hi", hit ^S, then type
> "there", then hit ^Q, then, on the next line, ^D to end the file)
>
> Note that the "there" does not appear after hitting ^Q, but it does
> appear in the file. So the characters were accepted, but they were not
> echoed (not even saved for echo when the terminal is restarted).
>
> This behavior differs from that of FreeBSD (just tried it for fun -
> haven't tried other Unix's yet). I have noticed other times that the
> echo seems to get lost while the tty is stopped. Not sure if all this
> is related, but something seems amiss. Thoughts?

It should certainly occur if the output buffer is full but that shouldn't
be the case for a few bytes. Agreed the current behaviour is unexpected
and less than desirable so hack away.



\
 
 \ /
  Last update: 2008-08-07 21:57    [W:0.091 / U:8.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site