lkml.org 
[lkml]   [2008]   [Mar]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [regression] 2.6.25-rc4 snd-es18xx broken on Alpha
On 10-03-08 08:34, Michael Cree wrote:

> Bob Tracy wrote:

>> Supposedly with the ES1888, dma1 is for capture, dma2 is for playback.
>> dma2 == 5 is a 16-bit channel, yes? That could explain much...

It is, but what would it explain? You're only having playback problems, right?

>>
>> As for the values "chosen" for dma1 and dma2, they are the ones that
>> keep showing up in the Alpha sound "howto" postings/documents.
>
> Running 'show config' in SRM on my Alphas (PWS500au and XP1000) reveals
> the settings (except possibly for mpu_port) for the ESS1888 sound chip.
> I recall that they are as reported in Alpha sound howtos.

Can it be forced to use dma2=0 (an 8-bit channel, and the usual capture
channel on es18xx)? However, that might not be the issue anyway:

> I hadn't been using the ESS1888 for awhile, but have just tried it out
> since you reported problems. I am running kernel 2.6.24.3 and Debian
> testing on the XP1000. I tried playing a number of wav files with
> alsa's aplay, sox's play and with mocp. I found that aplay and mocp
> worked reliably through the ESS1888. Sox's play on some files did play
> back a small extra segment of the file - particularly on short files and
> usually some section near the end of the file - once it had completed
> playing the file once; maybe this is what you are also observing.

This sounds very suspiciously like a difference with playing through the
native ALSA interface and the OSS emulaion. Could you and/or Bob confirm
that sox is using the OSS emulation and not ALSA natively?

I could very well imagine the ALSA OSS emulation being broken on Alpha. I
doubt any of teh developers has an Alpha. And if aplay works correctly this
seems very likely.

"sox" _can_ use ALSA natively as well by the way (see manpage for the
version you have installed).

> More onerously, my testing eventually ended in a complete system lock up!
> I ran play (or was it aplay - sorry can't remember now)

Vital if play is using the OSS interface...

> and the system locked up. Got a response with ping across the network but
> couldn't log in via ssh. Have been playing mplayer through the ESS1888
> for the last couple of days (don't like it though - the sound quality of
> the ESS1888 is not good enough for my ears) and haven't had another one
> of those lockups since.

Mmm.

Rene.


\
 
 \ /
  Last update: 2008-03-10 16:19    [W:0.065 / U:3.828 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site