lkml.org 
[lkml]   [2008]   [Mar]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Subject[regression] 2.6.25-rc4 snd-es18xx broken on Alpha
Date
From
I feel bad about bringing this one up because I honestly have no idea
*when* the driver quit working. (I don't always have a spare set of
speakers available for the Alpha). This literally could have been
broken for months...

Symptoms:

(1) Using the sox-based "play" command to play a short ".wav" file
results in the file being played approx. 1.5 times, i.e., it plays
all the way through, then restarts from the beginning and quits
somewhere in the middle of the second playback. At least the
sound doesn't seem distorted...

(2) Using "mpg123" results in silence at first, then after about 30
seconds, a tight loop of random repeating sound (doesn't sound like
part of the mp3 file, but it's probably derived from it :-)) until
the process is forcibly killed.

I have to hit <ctrl>C twice to interrupt playback.

/proc/asound/cards looks normal:

0 [ES1888 ]: ES1888 - ESS AudioDrive ES1888
ESS AudioDrive ES1888 at 0x220, irq 5, dma1 1, dma2 5

Here are the ALSA module options I've always had defined in
/etc/modprobe.d/sound:

alias snd-card-0 snd-es18xx
alias sound-slot-0 snd-es18xx
options snd-es18xx enable=1 isapnp=0 port=0x220 irq=5 dma1=1 dma2=5 mpu_port=0x330

--
------------------------------------------------------------------------
Bob Tracy | "I was a beta tester for dirt. They never did
rct@frus.com | get all the bugs out." - Steve McGrew on /.
------------------------------------------------------------------------


\
 
 \ /
  Last update: 2008-03-08 05:01    [W:0.101 / U:1.164 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site