[lkml]   [2008]   [Jan]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCHv2] kprobes: Introduce is_kprobe_fault()
Harvey Harrison writes:

> Use a central is_kprobe_fault() inline in kprobes.h to remove all
> of the arch-dependant, practically identical implementations in
> avr32, ia64, powerpc, s390, sparc64, and x86.

I don't like the name "is_kprobe_fault" since the function actually
handles the fault - i.e. it does more than just tell the caller
whether this is a kprobes fault. Something like
"handle_kprobes_fault" or "maybe_handle_kprobes_fault" would be
better IMO.


 \ /
  Last update: 2008-01-08 23:49    [W:0.047 / U:11.904 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site