[lkml]   [2008]   [Jan]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCHv2] kprobes: Introduce is_kprobe_fault()
On Wed, 2008-01-09 at 09:45 +1100, Paul Mackerras wrote:
> Harvey Harrison writes:
> > Use a central is_kprobe_fault() inline in kprobes.h to remove all
> > of the arch-dependant, practically identical implementations in
> > avr32, ia64, powerpc, s390, sparc64, and x86.
> I don't like the name "is_kprobe_fault" since the function actually
> handles the fault - i.e. it does more than just tell the caller
> whether this is a kprobes fault. Something like
> "handle_kprobes_fault" or "maybe_handle_kprobes_fault" would be
> better IMO.

Good point, I chose the name based simply on the usage pattern found
in all the callers. Of your suggestions I like handle_kprobes_fault

How about check_kprobes_fault? That seems to cover what you were
getting at with maybe_handle_kprobes_fault but is shorter. That
also fits better with the !CONFIG_KPROBES case.


 \ /
  Last update: 2008-01-09 00:05    [W:0.057 / U:3.556 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site