[lkml]   [2004]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 4/4] move semaphore definitions to waitlock_types.h
On Thu, Oct 14, 2004 at 11:45:20PM +0200, Roman Zippel wrote:
> This moves the definition and initializer of semaphore, rw_semaphore and
> wait queue structures to waitlock_types.h.

The name is really horrible. If absolutely needed they should go into
{rwsem,semaphore}_t.h or something similar derived from the main header
names. But I must say I really hate this kind of separation as it makes
the code rather hard to follow.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 14:07    [W:0.046 / U:10.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site