[lkml]   [2004]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 4/4] move semaphore definitions to waitlock_types.h
On Thu, Oct 14, 2004 at 11:05:54PM +0100, Christoph Hellwig wrote:
> On Thu, Oct 14, 2004 at 11:45:20PM +0200, Roman Zippel wrote:
> >
> > This moves the definition and initializer of semaphore, rw_semaphore and
> > wait queue structures to waitlock_types.h.
> But I must say I really hate this kind of separation as it makes
> the code rather hard to follow.

You do? This is essentially the same separation as putting code in .c files and
data definitions in .h files.

Mathematics is the supreme nostalgia of our time.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 14:07    [W:0.030 / U:1.100 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site