[lkml]   [2004]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 4/4] move semaphore definitions to waitlock_types.h

On Thu, 14 Oct 2004, Christoph Hellwig wrote:

> > This moves the definition and initializer of semaphore, rw_semaphore and
> > wait queue structures to waitlock_types.h.
> The name is really horrible.

Why? Actually I find it quite logical, we have types.h and posix_types.h.
waitlock_types.h describes rather well what it contains.

> names. But I must say I really hate this kind of separation as it makes
> the code rather hard to follow.

The code is still where it was before. :)
It's just a bit unfamiliar that the types are in separate header, but not
doing this means we can't use any inline functions or next time we want
restructure anything, you are busy to get everything compiled again.
I'm open to better ideas, but I don't see a way around this.

bye, Roman
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 14:07    [W:0.037 / U:2.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site