[lkml]   [2002]   [Jul]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: PATCH - mark 2: type safe(r) list_entry repacement: con
    On 24 Jul 02 at 22:38, Neil Brown wrote:
    > With the "typeof" suggestion from Kevin, I could just change
    > list_entry and not woory about the fact that lots of people use
    > "list_entry" for things that aren't lists.... but I didn't.

    is list_entry name really that bad? We have well established
    list_entry name since at least 2.2.0, and having two same functions
    with two different names will (IMHO) cause more damage than benefit
    from "clearer" name is.
    Petr Vandrovec

    P.S.: I converted whole matroxfb to use
    list_entry(xxx, struct matrox_fb_info, fbcon) instead of
    (struct matrox_fb_info*)xxx so that I can move fbcon field from
    first position in matrox_fb_info - so I'm personally interested
    in backward source compatibility.
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:27    [W:0.029 / U:42.184 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site