[lkml]   [2002]   [Jul]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: PATCH - mark 2: type safe(r) list_entry repacement: con
On Wednesday July 24, wrote:
> On 24 Jul 02 at 22:38, Neil Brown wrote:
> >
> > With the "typeof" suggestion from Kevin, I could just change
> > list_entry and not woory about the fact that lots of people use
> > "list_entry" for things that aren't lists.... but I didn't.
> Hello,
> is list_entry name really that bad? We have well established
> list_entry name since at least 2.2.0, and having two same functions
> with two different names will (IMHO) cause more damage than benefit
> from "clearer" name is.

Well... "list_entry" is fine when you are working with a list... but
when you aren't it is downright confusing.

The two functions (actually macros) have the same body, but have
conceptually different uses. Having extra clues in the code to help
readers know what is happening is a *good*thing*.

> Thanks,
> Petr Vandrovec
> P.S.: I converted whole matroxfb to use
> list_entry(xxx, struct matrox_fb_info, fbcon) instead of
> (struct matrox_fb_info*)xxx so that I can move fbcon field from
> first position in matrox_fb_info - so I'm personally interested
> in backward source compatibility.

In the final patch backward source compatability was not broken, so
you should be fine.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:22    [W:0.036 / U:1.280 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site