lkml.org 
[lkml]   [2001]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Unresponiveness of 2.4.16 revisited
"Nathan G. Grennan" wrote:
>
> Well I tried your patch Andrew. It seemed to have absolutely no effect
> on my problem. I used the am-response.patch someone posted the url to
> eariler in the first thread, which was just a file of your patch. I
> really suggest you try a mozilla source rpm. Not only does it do the
> unarchiving, but also patches and rm -rf. I often see a second pause
> during the patching after the unarchving. I use
>
> rpm --rebuild mozilla-2001112602_trunk-0_rh7.src.rpm
>
> I also tried Redhat's latest rawhide kernel, 2.4.16-0.1 and it had to
> had time same problem. So it isn't fixed by one of their patchs. It is
> most likely just a difference between Linus's 2.4.9 and 2.4.16.

Nathan,

I can reproduce the 30 second stall on ext3. It is due to
ext3's journalling of atime updates. Even though everything
is in cache, running an application requires a write to the
inode. If there's a lot of write activity going on, this can
occasionally cause the seemingly-read-only caller to get stuck
on the queue behind a huge amount of writes. So of course the
read-latency improvements don't help.

The 2.2 kernel's version of ext3 didn't journal atime updates,
and this may be a reason for going back to that scheme. Needs
thought and more testing.

However I can't reproduce the stalls on ext2, and I would expect
the 2.4.9 kernel's ext3 to be demonstrating the same stalls.

Could you please confirm that the stalls happen with ext2 as well,
and could you please test ext2 and ext3 with the `noatime' mount
option?

Thanks.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.046 / U:4.416 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site