lkml.org 
[lkml]   [2001]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Unresponiveness of 2.4.16 revisited
On Wed, Nov 28, 2001 at 10:30:32PM -0800, Andrew Morton wrote:
> "Nathan G. Grennan" wrote:
> >
> > Well I tried your patch Andrew. It seemed to have absolutely no effect
> > on my problem. I used the am-response.patch someone posted the url to
> > eariler in the first thread, which was just a file of your patch. I
> > really suggest you try a mozilla source rpm. Not only does it do the
> > unarchiving, but also patches and rm -rf. I often see a second pause
> > during the patching after the unarchving. I use
> >
> > rpm --rebuild mozilla-2001112602_trunk-0_rh7.src.rpm
> >
> > I also tried Redhat's latest rawhide kernel, 2.4.16-0.1 and it had to
> > had time same problem. So it isn't fixed by one of their patchs. It is
> > most likely just a difference between Linus's 2.4.9 and 2.4.16.
>
> Nathan,
>
> I can reproduce the 30 second stall on ext3. It is due to

Just recently I had to run badblocks -ws on a scsi hard drive. It was on
its own scsi controller. During the write portions, I was able to see
pauses of 1-5 seconds. Mouse didn't move, nothing. During the read
(compare) portion, there were no such pauses.

This was on vanilla 2.4.16. 2x366 celeron, and 256MB ram. Only reading with
mutt, and irc. gkrellm showed the pauses.

00:00.0 Host bridge: Intel Corp. 440LX/EX - 82443LX/EX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440LX/EX - 82443LX/EX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corp. 82371AB PIIX4 ISA (rev 01)
00:07.1 IDE interface: Intel Corp. 82371AB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB PIIX4 ACPI (rev 01)
00:08.0 SCSI storage controller: Adaptec AIC-7881U (rev 01)
00:0a.0 Ethernet controller: Digital Equipment Corporation DECchip 21041 [Tulip Pass 3] (rev 21)
00:0b.0 Ethernet controller: Intel Corp. 82557 [Ethernet Pro 100] (rev 08)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G100 [Productiva] AGP (rev 01)

mf
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.056 / U:4.404 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site