lkml.org 
[lkml]   [1998]   [Jul]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRequest for stats: devfs and kmod errors
  Hi, all. I've had at least two reports of errors like:
kmod: waitpid(%d,NULL,0) failed, returning = -512.

when using 2.1.11x kernels with my devfs patch (and apparently the
errors go away when devfs is not used). Something I'm trying to
establish whether anything *actually fails* when this message pops
up. I'm starting to suspect that it's an annoying message and nothing
more: no functionality is lost.

Secondly, I also suspect that devfs *is not* causing these
messages. Rather, using devfs increases the incidence of calls to
request_module(), and hence you're more likely to see these messages,
because there is still an underlying problem with kmod. Therefore I
would dearly like to hear from people who *don't* use devfs but still
get these error messages. I'd also like to know if the message is
associated with any actual failures in operation, or if it's just an
annoying message.

I had originally suspected a nasty deadlock problem with the /dev
directory semaphore, but having run strace(1) on modprobe(1), I don't
see how that can be happening.

Regards,

Richard....
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.altern.org/andrebalsa/doc/lkml-faq.html

\
 
 \ /
  Last update: 2005-03-22 13:43    [from the cache]
©2003-2011 Jasper Spaans