lkml.org 
[lkml]   [1996]   [Apr]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: Must modules be GPL'ed?
Kevin Lentin (kevinl@cs.monash.EDU.AU) wrote:

: I think one of the reasons for having modules was the ability for people to
: supply binary modules.

I am absolutely ignorant in copyrighting-licensing-etc... stuff,
but I feel that it would be wrong to ALLOW to supply binary modules.

F.e. there exist obsolete binary drivers for riscom/n2 and et cards.
Good, linux-2.0 will be issued tomorrow, SDL and ETinc. will issue new binary
drivers in half of year. By this time, linux-2.0 will be obsoleted
by 2.1, as it occured with 1.2.13 ...

It would be better not to have them at all.

Alexey Kuznetsov.


\
 
 \ /
  Last update: 2005-03-22 13:36    [W:0.071 / U:0.660 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site