[lkml]   [1996]   [Dec]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: IOMEGA ZIP & LINUX; can't boot from AHA2840

> Hi!:
> I'm going to buy this unit because of its cost but I've
> read the
> kernel 2.0.12 Documentation about this unit and I'd like to know if
> Linux has any problem in the 'real' world with this kind of device,
> maybe someone with experience ... At the moment I must only have the
> printer daemon and the zip driver as a modules and insmod/rmmod them
> each time I want to use it, no? (I have a single paralel port on my
> machine). What about kernel 1.2.13?
> Bye.
> Jose.
> - --
> Jose Manuel Laveda Molina.
> Cullera - Valencia - SPAIN

I use the ZIP with Linux 2.0.27. Yes, last I heard you still have to rmmod
the ppa driver to load the printer one, but I don't think I've tried to
print since I've had the ZIP hooked up. I also notice that even though
I compiled the ppa driver as a module, it loads along with the kernel and
becomes my first scsi device. This is somewhat of a nuisance since if
I were to remove the ZIP, the devices for my SCSI hard drive and Jaz drive
would change. I also think maybe once I tried to remove the ppa module
and it pretended to do it but I still saw it in lsmod. But I don't remember
that for sure. At any rate, get the SCSI Zip if you can; the parallel
one is so slow, most CD drives these days can outrun it. You can always
get a separate //-port scsi adapter if you occasionally might need the
drive somewhere else on a Windows machine or whatever (like I do). Too
bad that costs more. :-(

On a related note, I'm having trouble getting my Adaptec 2840 (I think -
the VL one) to load its BIOS, and this causes LILO not to be able to
see my SCSI hard drive for booting purposes (I get L, then 01 01 01
forever; that's with LILO installed on the boot sector of my IDE drive).
I have the DIP switch set properly, and the SCSI Select "load bios"
parameter set to on as well. The boot messages look something like

<Press Control-A for SCSISelect>

HD Conner 1060 meg
Jaz 1 gig

Bios not installed!

<end quote>
This does not interfere with the kernel's ability to find the two SCSI
drives, once it has booted off an IDE drive. But I wanted to switch
over to having it boot off the SCSI drive to gain the speed (it benchmarks
at 3-4 times faster). I figured LILO probably needs that BIOS installed,
and that the BIOS provides it the ability to read specific sectors off
the disk to load the kernel. Right? So, any ideas on how to make it load?

_______ KB7PWD @ KC7Y.AZ.US.NOAM
(_ | |_) Shawn T. Rutledge on the web:
__) | | \__________________________________________________________________
* let freedom ring * robotics * freedom of information * Interpedia *

 \ /
  Last update: 2005-03-22 13:38    [W:0.037 / U:0.768 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site