lkml.org 
[lkml]   [2024]   [Apr]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [RFC PATCH v2 1/6] dt-bindings: ROHM BD96801 PMIC regulators
From
On 12/04/2024 13:21, Matti Vaittinen wrote:
> ROHM BD96801 is a highly configurable automotive grade PMIC. Introduce
> DT bindings for the BD96801 regulators.
>
> Signed-off-by: Matti Vaittinen <mazziesaccount@gmail.com>
> ---
> Revision history:
> - No changes since RFCv1

Subject: missing "regulator" prefix, as first.

>
> .../regulator/rohm,bd96801-regulator.yaml | 69 +++++++++++++++++++
> 1 file changed, 69 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/regulator/rohm,bd96801-regulator.yaml
>
> diff --git a/Documentation/devicetree/bindings/regulator/rohm,bd96801-regulator.yaml b/Documentation/devicetree/bindings/regulator/rohm,bd96801-regulator.yaml
> new file mode 100644
> index 000000000000..4015802a3d84
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/regulator/rohm,bd96801-regulator.yaml
> @@ -0,0 +1,69 @@
> +# SPDX-License-Identifier: GPL-2.0-only OR BSD-2-Clause
> +%YAML 1.2
> +---
> +$id: http://devicetree.org/schemas/regulator/rohm,bd96801-regulator.yaml#
> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: ROHM BD96801 Power Management Integrated Circuit regulators
> +
> +maintainers:
> + - Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
> +
> +description: |
> + This module is part of the ROHM BD96801 MFD device. For more details
> + see Documentation/devicetree/bindings/mfd/rohm,bd96801-pmic.yaml.
> +
> + The regulator controller is represented as a sub-node of the PMIC node
> + on the device tree.
> +
> + Regulator nodes should be named to BUCK_<number> and LDO_<number>.
> + The valid names for BD96801 regulator nodes are
> + BUCK1, BUCK2, BUCK3, BUCK4, LDO5, LDO6, LDO7
> +
> +patternProperties:
> + "^LDO[5-7]$":

lowercase

> + type: object
> + description:
> + Properties for single LDO regulator.
> + $ref: regulator.yaml#

Missing unevaluatedProperties: false

> +
> + properties:
> + regulator-name:
> + pattern: "^ldo[5-7]$"
> + description:
> + Name of the regulator. Should be "ldo5", ..., "ldo7"

Why do you enforce the name? The name should match board schematics, not
regulator datasheet.

> + rohm,initial-voltage-microvolt:
> + description:
> + Initial voltage for regulator. Voltage can be tuned +/-150 mV from
> + this value. NOTE, This can be modified via I2C only when PMIC is in
> + STBY state.
> + minimum: 300000
> + maximum: 3300000

Hm, regulator min/max microvolts properties don't work for you? The
initial will be just middle?

> +
> + "^BUCK[1-4]$":

lowercase

> + type: object
> + description:
> + Properties for single BUCK regulator.
> + $ref: regulator.yaml#
> +
> + properties:
> + regulator-name:
> + pattern: "^buck[1-4]$"
> + description:
> + should be "buck1", ..., "buck4"
> + rohm,initial-voltage-microvolt:
> + description:
> + Initial voltage for regulator. Voltage can be tuned +/-150 mV from
> + this value. NOTE, This can be modified via I2C only when PMIC is in
> + STBY state.
> + minimum: 500000
> + maximum: 3300000

Missing blank line

> + rohm,keep-on-stby:
> + description:
> + Keep the regulator powered when PMIC transitions to STBY state.
> + type: boolean
> +
> + required:
> + - regulator-name
> + additionalProperties: false

Blank line

> +additionalProperties: false

Best regards,
Krzysztof


\
 
 \ /
  Last update: 2024-04-13 23:28    [W:1.180 / U:0.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site