lkml.org 
[lkml]   [2008]   [Nov]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/5] adt7462: New hwmon driver
On Fri, 07 Nov 2008 11:04:51 -0800
Harvey Harrison <harvey.harrison@gmail.com> wrote:

> On Fri, 2008-11-07 at 10:56 -0800, Darrick J. Wong wrote:
> > New driver to play with. As Jean mentioned a couple of years ago,
> > this
> > chip is a beast with odd combinations of 8 fans, 4 temperatures, and
> > 13 voltage sensors. This driver has been tested on an IntelliStation
> > Z30.
> >
> > Signed-off-by: Darrick J. Wong <djwong@us.ibm.com>
> > ---
> > +#define MASK_AND_SHIFT(value, prefix) \
> > + (((value) & prefix##_MASK) >> prefix##_SHIFT)
> > +
>
> I'm not sure, but doesn't this exist somewhere in the common kernel
> headers.

No, core kernel doesn't have a macro which requires that the caller
previously defined foo_MASK and foo_SHIFT. Only drivers are allowed to
get away with such fugliness ;)

> > +#define ROUND_DIV(x, divisor) (((x) + ((divisor) / 2)) / (divisor))
>
> DIV_ROUND_UP ?

That's different. This one should be called ROUND_CLOSEST or something
like that.



\
 
 \ /
  Last update: 2008-11-07 20:31    [W:0.169 / U:0.244 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site