lkml.org 
[lkml]   [1999]   [Apr]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectLinux 2.2.x corrupting ext2 partitions (seagate medlist hdd)

Hi all,

Note: I have tried to ensure that this is _not_ a hardware error, but I can
not convince myself of that. However I have never seen an error like this, so
I believe it warants some attention. If you believe it is hardware related
then let me know!

Firstly a run down of the problematic system.

- Aopen Ax63 MB
- Intel Celeron 333 CPU
- 3com 3c509 100Mb Etherlink-XL
- SB 16 (unused)
- Mitsumi CD-Rom
- Creative Graphics Blaster TNT
- 6.4GB Seagate Medalist HDD (ST36422A)


The HDD is partitioned as follows (output from fdisk):

Boot Start End Blocks Id System
/dev/hda1 * 1 192 1542208+ 6 DOS 16-bit >= 32M
/dev/hda2 193 205 104422+ 82 Linux Swap
/dev/hda3 206 460 2048287+ 83 Linux Native
/dev/hda4 461 778 2554335 5 Extended
/dev/hda5 461 778 2554303 b Win95 FAT32



The bug/problem is as follows:

1. Installed Debian Linux 2.1 (slink) onto /dev/hda3 (successful
installation - system is stable (tested multiple reboots), running
kernel 2.0.36)
2. Upgraded kernel to Linux 2.2.5 (also tested with 2.2.3).
3. System reboots fine and new kernel functions correctly.
4. On next boot, the root partition is reported as corrupted (see error
messages below).
5. The partition is no longer accessable via 2.0.36 or any other kernel.
6. After attempting to fix with e2fsck most files are absent (in lost+found)

Note that it _only_ happens on the _2nd_ boot after upgrading to Linux 2.2.x
and that machine was correctly shutdown at every stage.

Lastly, I have had this same system working with kernel 2.2.3 before, with
a Quantum Fireball SE drive instead of the seagate drive.

Also, I tried this with various kernel configurations, with the same results.
If you would like a copy of the kernel/configuration then please ask.



Error messages:

This is the relevant part of the boot up messages:

VP_IDE: IDE controller on PCI bus 00 dev 39
VP_IDE: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0x6400 - 0x6407, BIOS settings: hda:pio, hdb:pio
ide1: BM-DMA at 0x6408 - 0x640f, BIOS settings: hdc:pio, hdd:pio
hda: ST36422A, 6103MB w/256kB Cache, CHS=778/255/63, UDMA
hdd: ATAPI 27x CD-ROM drive, 120kB Cache
Uniform CDROM driver Revision: 2.52
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
3c59x.c: V0.99H 11/17/98 Donald Becker http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html
eth0: 3Com 3c905 Boomerang 100baseTx at 0x6c00, 00:60:08:65:c5:0c, IRQ 11
8k word-wide RAM 3:5 Rx:Tx split, autoselect/MII interface.
MII transceiver found at address 24, status 786f
Enabling bus-master transmits and whole frame receives.
Partition check
hda: hda1 hda2 hda3 hda4 <hda5>
EXT2-fs error (device 03:03): ext2_check_descriptors: Inode bitmap for group 1 not in group (block 0)!
EXT2-fs: group descriptors corrupted!
[MS-DOS FS Rel. 12,FAT 0,check=n,conv=b,uid=0,gid=0,umask=022,bmap]
[me=0x47,cs=0,#f=36,fs=65526,fl=140830,ds=572530,de=0,data=5725230,se=64000,ts=-836173555,ls=5120,rc=0,fc=4294967295]
Transaction block size = 512
[me=0x47,cs=0,#f=36,fs=65526,fl=140830,ds=572530,de=0,data=5725230,se=64000,ts=-836173555,ls=5120,rc=0,fc=4294967295]
Transaction block size = 512
Kernel panic: VFS: Unable to mount root fs on 03:03





Thanks for any assistance,

Chris Leishman

--

----------------------------------------------------------------------
The box said "Windows 95, NT or better" .. so I installed Debian Linux
----------------------------------------------------------------------
Reply with subject 'request key' for PGP public key. KeyID 0xA9E087D5[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 13:51    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site