lkml.org 
[lkml]   [2023]   [Jan]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH v1] thermal: intel: int340x: Fix unitialized variable error
Date
From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>

If PATC evaluation fails in int340x_thermal_zone_add(), trip_cnt will
not be initialized when allocating the trips array later.

Address this by initializing trip_cnt to 0.

While at it, move the status variable definition lower for better
code readability.

Fixes: d58c653e9e26 ("thermal: intel: int340x: Use generic trip points")
Reported-by: Dan Carpenter <error27@gmail.com>
Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
---
drivers/thermal/intel/int340x_thermal/int340x_thermal_zone.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Index: linux-pm/drivers/thermal/intel/int340x_thermal/int340x_thermal_zone.c
===================================================================
--- linux-pm.orig/drivers/thermal/intel/int340x_thermal/int340x_thermal_zone.c
+++ linux-pm/drivers/thermal/intel/int340x_thermal/int340x_thermal_zone.c
@@ -120,9 +120,9 @@ struct int34x_thermal_zone *int340x_ther
int (*get_temp) (struct thermal_zone_device *, int *))
{
struct int34x_thermal_zone *int34x_thermal_zone;
- acpi_status status;
- unsigned long long trip_cnt;
+ unsigned long long trip_cnt = 0;
int trip_mask = 0;
+ acpi_status status;
int i, ret;

int34x_thermal_zone = kzalloc(sizeof(*int34x_thermal_zone),


\
 
 \ /
  Last update: 2023-03-26 23:54    [W:0.089 / U:0.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site