lkml.org 
[lkml]   [2021]   [Jun]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
Subject[GIT PULL] PNP updates for v5.14-rc1
Hi Linus,

Please pull from the tag

git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git \
pnp-5.14-rc1

with top-most commit 17aa26c96fb240de92db90ec1bfd616f28b6dc16

PNP: pnpbios: Use list_for_each_entry() instead of list_for_each()

on top of commit d07f6ca923ea0927a1024dfccafc5b53b61cfecc

Linux 5.13-rc2

to receive PNP updates for 5.14-rc1.

These get rid of unnecessary local variables and function, reduce
code duplication and clean up message printing.

Specifics:

- Remove unnecessary local variables from isapnp_proc_attach_device()
(Anupama K Patil).

- Make the callers of pnp_alloc() use kzalloc() directly and drop
the former (Heiner Kallweit).

- Make two pieces of code use dev_dbg() instead of dev_printk() with
the KERN_DEBUG message level (Heiner Kallweit).

- Use DEVICE_ATTR_RO() instead of full DEVICE_ATTR() in some places
in card.c (Zhen Lei).

- Use list_for_each_entry() instead of list_for_each() in
insert_device() (Zou Wei).

Thanks!


---------------

Anupama K Patil (1):
drivers: pnp: isapnp: proc.c: Remove unnecessary local variables

Heiner Kallweit (2):
PNP: Remove pnp_alloc()
PNP: Switch over to dev_dbg()

Zhen Lei (1):
PNP: use DEVICE_ATTR_RO macro

Zou Wei (1):
PNP: pnpbios: Use list_for_each_entry() instead of list_for_each()

---------------

drivers/pnp/base.h | 1 -
drivers/pnp/card.c | 14 +++++++-------
drivers/pnp/core.c | 17 ++---------------
drivers/pnp/interface.c | 4 ++--
drivers/pnp/isapnp/proc.c | 13 ++++++-------
drivers/pnp/pnpbios/core.c | 4 +---
drivers/pnp/resource.c | 2 +-
7 files changed, 19 insertions(+), 36 deletions(-)

\
 
 \ /
  Last update: 2021-06-29 21:04    [W:0.435 / U:2.496 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site