lkml.org 
[lkml]   [2020]   [Jun]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] linux++, this: rename "struct notifier_block *this"
On Friday 2020-06-19 09:46, Christoph Hellwig wrote:

>On Fri, Jun 19, 2020 at 12:06:45AM +0300, Alexey Dobriyan wrote:
>> Rename
>> struct notifier_block *this
>> to
>> struct notifier_block *nb
>>
>> "nb" is arguably a better name for notifier block.
>
>But not enough better to cause tons of pointless churn. Feel free
>to use better naming in new code you write or do significant changes
>to, but stop these pointless renames.

Well, judging from the mention of "linux++" in the subject, I figure
this is the old discussion of someone trying to make Linux code, or
parts thereof, work in a C++ environment. Since the patch does not just
touch headers but .c files, I deduce that there seems to be a project
trying to build Linux, or a subset thereof, as a C++ program for the fun
of it. UML could come to mind.

Is it a hot potato? Definitely. But so was IPv6 NAT, and now we have it
anyway.

\
 
 \ /
  Last update: 2020-06-19 12:30    [W:0.109 / U:0.972 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site