lkml.org 
[lkml]   [2020]   [Dec]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v2 2/4] configfs: use BIT() for internal flags
On Tue, Dec 1, 2020 at 12:22 PM Christoph Hellwig <hch@lst.de> wrote:
>
> On Mon, Nov 30, 2020 at 05:47:02PM +0100, Bartosz Golaszewski wrote:
> > From: Bartosz Golaszewski <bgolaszewski@baylibre.com>
> >
> > For better readability and maintenance: use the BIT() macro for flag
> > definitions.
>
> This does not improve readability, as I now need to look up a macro,
> one that doesn't make any sense at all. If you really prefer bit based
> numbering just use the totally obvious (1 << bit) syntax.

(1 << bit) is better than a number in hex but BIT() has been in the
kernel for so long that I doubt anyone needs to look it up.

Anyway, it's your call, it'll be (1 << bit) in v3.

Bartosz

\
 
 \ /
  Last update: 2020-12-01 15:11    [W:0.067 / U:0.524 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site