[lkml]   [2020]   [Dec]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2 2/4] configfs: use BIT() for internal flags
On Mon, Nov 30, 2020 at 05:47:02PM +0100, Bartosz Golaszewski wrote:
> From: Bartosz Golaszewski <>
> For better readability and maintenance: use the BIT() macro for flag
> definitions.

This does not improve readability, as I now need to look up a macro,
one that doesn't make any sense at all. If you really prefer bit based
numbering just use the totally obvious (1 << bit) syntax.

 \ /
  Last update: 2020-12-01 12:25    [W:0.094 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site