lkml.org 
[lkml]   [2020]   [Nov]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v2 1/3] spi: convert to BIT() all spi_device flags
On Tue, Nov 24, 2020 at 12:16 PM Alexandru Ardelean
<alexandru.ardelean@analog.com> wrote:
>
> This change converts all bit flags for the 'struct spi_device' mode to the
> BIT() macro. The change is mostly for readability. Since adding more bit
> fields, might as well convert it now.

...

#include <linux/bits.h>

And honestly I think the entire inclusion block with data type forward
declarations should be revisited here.

...

> +#define SPI_CPHA BIT(0) /* clock phase */
> +#define SPI_CPOL BIT(1) /* clock polarity */

--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2020-11-24 12:49    [W:0.742 / U:0.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site