lkml.org 
[lkml]   [2019]   [Jul]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v10 3/6] usb:common Patch simplify usb_decode_set_clear_feature function.
From
Date
On Sun, 2019-07-21 at 19:32 +0100, Pawel Laszczak wrote:
> Patch adds usb_decode_test_mode and usb_decode_device_feature functions,
> which allow to make more readable and simplify the
> usb_decode_set_clear_feature function.

<chuckle> I need to read entire patch series before
commenting more I guess...

> Signed-off-by: Pawel Laszczak <pawell@cadence.com>
> ---
> drivers/usb/common/debug.c | 89 ++++++++++++++++++--------------------
> 1 file changed, 43 insertions(+), 46 deletions(-)
>
> diff --git a/drivers/usb/common/debug.c b/drivers/usb/common/debug.c
[]
> +static const char *usb_decode_device_feature(u16 wValue)

I believe this is still unnecessary hungarian.

> +{
> + switch (wValue) {
> + case USB_DEVICE_SELF_POWERED:
> + return "Self Powered";
> + case USB_DEVICE_REMOTE_WAKEUP:
> + return "Remote Wakeup";
> + case USB_DEVICE_TEST_MODE:
> + return "Test Mode";
> + case USB_DEVICE_U1_ENABLE:
> + return "U1 Enable";
> + case USB_DEVICE_U2_ENABLE:
> + return "U2 Enable";
> + case USB_DEVICE_LTM_ENABLE:
> + return "LTM Enable";
> + default:
> + return "UNKNOWN";
> + }
> +}

But yeah, exactly like this... ;)


\
 
 \ /
  Last update: 2019-07-21 21:08    [W:0.314 / U:0.200 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site