lkml.org 
[lkml]   [2018]   [Feb]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 6/7] sched: Rename root_domain->overload to should_idle_balance
Hi,

On 15/02/18 16:20, Morten Rasmussen wrote:
> From: Valentin Schneider <valentin.schneider@arm.com>
>
> The name "overload" is not very explicit, especially since it doesn't
> use any concept of "load" coming from load-tracking signals. For now it
> simply tracks if any of the CPUs in root_domain has more than one
> runnable task, and is then used to decide whether idle balance should be
> performed.
>
> As such, this commit changes that flag's name to 'should_idle_balance',
> which makes its role more explicit.
>
> cc: Ingo Molnar <mingo@redhat.com>
> cc: Peter Zijlstra <peterz@infradead.org>
> Suggested-by: Patrick Bellasi <patrick.bellasi@arm.com>
> Signed-off-by: Valentin Schneider <valentin.schneider@arm.com>
> Signed-off-by: Morten Rasmussen <morten.rasmussen@arm.com>
> ---

[...]

> diff --git a/kernel/sched/sched.h b/kernel/sched/sched.h
> index 7d324b706e67..4215438667e5 100644
> --- a/kernel/sched/sched.h
> +++ b/kernel/sched/sched.h
> @@ -650,8 +650,12 @@ struct root_domain {
> cpumask_var_t span;
> cpumask_var_t online;
>
> - /* Indicate more than one runnable task for any CPU */
> - bool overload;
> + /*
> + * Indicate whether the idle balance can be used to solve
> + * imbalance within the root domain.
> + * e.g. There is more than one runnable task for any CPU
> + */
> + bool should_idle_balance;

Current name is however consistent with RT/DL's naming convention

[...]
/*
* The bit corresponding to a CPU gets set here if such CPU has more
* than one runnable -deadline task (as it is below for RT tasks).
*/
cpumask_var_t dlo_mask;

[...]

/*
* The "RT overload" flag: it gets set if a CPU has more than
* one runnable RT task.
*/
cpumask_var_t rto_mask;

Not a big deal, though. Just wanted to point that out. :)

Best,

- Juri

\
 
 \ /
  Last update: 2018-02-16 10:15    [W:0.374 / U:0.408 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site