[lkml]   [2018]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_
Geert Uytterhoeven <> writes:

> On Tue, Jan 2, 2018 at 10:45 AM, Michael Ellerman <> wrote:
>> Christoph Hellwig <> writes:
>>> We want to use the dma_direct_ namespace for a generic implementation,
>>> so rename powerpc to the second best choice: dma_nommu_.
>> I'm not a fan of "nommu". Some of the users of direct ops *are* using an
>> IOMMU, they're just setting up a 1:1 mapping once at init time, rather
>> than mapping dynamically.
>> Though I don't have a good idea for a better name, maybe "1to1",
>> "linear", "premapped" ?
> "identity"?

I think that would be wrong, but thanks for trying to help :)

The address on the device side is sometimes (often?) offset from the CPU
address. So eg. the device can DMA to RAM address 0x0 using address

Identity would imply 0 == 0 etc.

I think "bijective" is the correct term, but that's probably a bit


 \ /
  Last update: 2018-01-03 07:25    [W:0.110 / U:13.776 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site