[lkml]   [2018]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_
Hi Michael,

On Wed, Jan 3, 2018 at 7:24 AM, Michael Ellerman <> wrote:
> Geert Uytterhoeven <> writes:
>> On Tue, Jan 2, 2018 at 10:45 AM, Michael Ellerman <> wrote:
>>> Christoph Hellwig <> writes:
>>>> We want to use the dma_direct_ namespace for a generic implementation,
>>>> so rename powerpc to the second best choice: dma_nommu_.
>>> I'm not a fan of "nommu". Some of the users of direct ops *are* using an
>>> IOMMU, they're just setting up a 1:1 mapping once at init time, rather
>>> than mapping dynamically.
>>> Though I don't have a good idea for a better name, maybe "1to1",
>>> "linear", "premapped" ?
>> "identity"?
> I think that would be wrong, but thanks for trying to help :)
> The address on the device side is sometimes (often?) offset from the CPU
> address. So eg. the device can DMA to RAM address 0x0 using address
> 0x800000000000000.
> Identity would imply 0 == 0 etc.
> I think "bijective" is the correct term, but that's probably a bit
> esoteric.

OK, didn't know about the offset.
Then "linear" is what we tend to use, right?



Geert Uytterhoeven -- There's lots of Linux beyond ia32 --

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds

 \ /
  Last update: 2018-01-03 08:50    [W:0.109 / U:1.456 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site