lkml.org 
[lkml]   [2017]   [Oct]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 08/13] xen/pvcalls: implement accept command
On Thu, 21 Sep 2017, Boris Ostrovsky wrote:
> > +int pvcalls_front_accept(struct socket *sock, struct socket *newsock, int
> > flags)
> > +{
> > + struct pvcalls_bedata *bedata;
> > + struct sock_mapping *map;
> > + struct sock_mapping *map2 = NULL;
> > + struct xen_pvcalls_request *req;
> > + int notify, req_id, ret, evtchn, nonblock;
> > +
> > + pvcalls_enter;
> > + if (!pvcalls_front_dev) {
> > + pvcalls_exit;
> > + return -ENOTCONN;
> > + }
> > + bedata = dev_get_drvdata(&pvcalls_front_dev->dev);
> > +
> > + map = (struct sock_mapping *) sock->sk->sk_send_head;
> > + if (!map) {
> > + pvcalls_exit;
> > + return -ENOTSOCK;
> > + }
> > +
> > + if (map->passive.status != PVCALLS_STATUS_LISTEN) {
> > + pvcalls_exit;
> > + return -EINVAL;
> > + }
> > +
> > + nonblock = flags & SOCK_NONBLOCK;
> > + /*
> > + * Backend only supports 1 inflight accept request, will return
> > + * errors for the others
> > + */
> > + if (test_and_set_bit(PVCALLS_FLAG_ACCEPT_INFLIGHT,
> > + (void *)&map->passive.flags)) {
> > + req_id = READ_ONCE(map->passive.inflight_req_id);
> > + if (req_id != PVCALLS_INVALID_ID &&
> > + READ_ONCE(bedata->rsp[req_id].req_id) == req_id) {
> > + map2 = map->passive.accept_map;
> > + goto received;
> > + }
> > + if (nonblock) {
> > + pvcalls_exit;
> > + return -EAGAIN;
> > + }
> > + if (wait_event_interruptible(map->passive.inflight_accept_req,
> > + !test_and_set_bit(PVCALLS_FLAG_ACCEPT_INFLIGHT,
> > + (void *)&map->passive.flags))) {
> > + pvcalls_exit;
> > + return -EINTR;
> > + }
> > + }
> > +
> > + spin_lock(&bedata->socket_lock);
> > + ret = get_request(bedata, &req_id);
> > + if (ret < 0) {
> > + spin_unlock(&bedata->socket_lock);
> > + pvcalls_exit;
> > + return ret;
> > + }
> > + map2 = kzalloc(sizeof(*map2), GFP_KERNEL);
> > + if (map2 == NULL) {
> > + spin_unlock(&bedata->socket_lock);
> > + pvcalls_exit;
> > + return -ENOMEM;
> > + }
> > + ret = create_active(map2, &evtchn);
> > + if (ret < 0) {
> > + kfree(map2);
> > + spin_unlock(&bedata->socket_lock);
> > + pvcalls_exit;
> > + return -ENOMEM;
> > + }
>
> Do you need to clear PVCALLS_FLAG_ACCEPT_INFLIGHT bit on errors (except for
> EAGAIN/EINTR)?

Yes, you are right, I'll do that. Well spotted!


> > + list_add_tail(&map2->list, &bedata->socket_mappings);
> > +
> > + req = RING_GET_REQUEST(&bedata->ring, req_id);
> > + req->req_id = req_id;
> > + req->cmd = PVCALLS_ACCEPT;
> > + req->u.accept.id = (uint64_t) map;
> > + req->u.accept.ref = map2->active.ref;
> > + req->u.accept.id_new = (uint64_t) map2;
> > + req->u.accept.evtchn = evtchn;
> > + map->passive.accept_map = map2;
> > +
> > + bedata->ring.req_prod_pvt++;
> > + RING_PUSH_REQUESTS_AND_CHECK_NOTIFY(&bedata->ring, notify);
> > + spin_unlock(&bedata->socket_lock);
> > + if (notify)
> > + notify_remote_via_irq(bedata->irq);
> > + /* We could check if we have received a response before returning. */
> > + if (nonblock) {
> > + WRITE_ONCE(map->passive.inflight_req_id, req_id);
> > + pvcalls_exit;
> > + return -EAGAIN;
> > + }
> > +
> > + if (wait_event_interruptible(bedata->inflight_req,
> > + READ_ONCE(bedata->rsp[req_id].req_id) == req_id)) {
> > + pvcalls_exit;
> > + return -EINTR;
> > + }
> > +
> > +received:
> > + map2->sock = newsock;
> > + newsock->sk = kzalloc(sizeof(*newsock->sk), GFP_KERNEL);
> > + if (!newsock->sk) {
> > + WRITE_ONCE(bedata->rsp[req_id].req_id, PVCALLS_INVALID_ID);
> > + WRITE_ONCE(map->passive.inflight_req_id, PVCALLS_INVALID_ID);
> > + pvcalls_front_free_map(bedata, map2);
> > + kfree(map2);
> > + pvcalls_exit;
> > + return -ENOMEM;
> > + }
> > + newsock->sk->sk_send_head = (void *)map2;
> > +
> > + clear_bit(PVCALLS_FLAG_ACCEPT_INFLIGHT, (void *)&map->passive.flags);
> > + wake_up(&map->passive.inflight_accept_req);
> > +
> > + ret = bedata->rsp[req_id].ret;
> > + /* read ret, then set this rsp slot to be reused */
> > + smp_mb();
> > + WRITE_ONCE(bedata->rsp[req_id].req_id, PVCALLS_INVALID_ID);
> > + WRITE_ONCE(map->passive.inflight_req_id, PVCALLS_INVALID_ID);
>
> Should inflight_req_id be cleared at the same time as
> PVCALLS_FLAG_ACCEPT_INFLIGHT? They kind of belong together, don't they?

It is not necessary that they are cleared exactly at the same time but
it makes sense from a code readability point of view, so I'll do that.


> And I wonder whether you actually need the flag --- can you just key off
> map->passive.inflight_req_id not being PVCALLS_INVALID_ID?

We need the flag because we don't have the req_id at the beginning of
the accept function.


> (and again, I am not sure about all READ/WRITE_ONCE() macros here).

Yes, they are not needed

\
 
 \ /
  Last update: 2017-10-07 00:07    [W:1.780 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site