lkml.org 
[lkml]   [2014]   [Aug]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v4 0/3] usb: gadget: f_fs: userspace API fixes and improvements
Date
This patchset contains changes in FunctionFS making it easier and
safer to use. It fixes bug in endpoint files handling code, adds new
ioctl allowing to obtain endpoint descriptor, and introduces virtual
address mapping which allows to separate endpoint address space in
function from physical endpoint addresses, and introduces new endpoint
files naming convention.

Changelog:

v4:
- change if() sequence into switch() statement

v3: https://lkml.org/lkml/2014/7/30/115
- move fix for the redundant ep files problem into sepatare patch
- merge user space API affecting changes into single patch
- add flag switching between old and new style API

v2: https://lkml.org/lkml/2014/7/25/296
- return proper endpont address in setup request handling
- add patch usb: gadget: f_fs: add ioctl returning ep descriptor
- add patch usb: gadget: f_fs: make numbers in ep file names the same
as ep addresses

v1: https://lkml.org/lkml/2014/7/18/1010

Robert Baldyga (3):
usb: gadget: f_fs: fix the redundant ep files problem
usb: gadget: f_fs: add ioctl returning ep descriptor
usb: gadget: f_fs: virtual endpoint address mapping

drivers/usb/gadget/function/f_fs.c | 111 +++++++++++++++++++++++++++++++-----
drivers/usb/gadget/function/u_fs.h | 4 ++
include/uapi/linux/usb/functionfs.h | 7 +++
3 files changed, 109 insertions(+), 13 deletions(-)

--
1.9.1



\
 
 \ /
  Last update: 2014-08-20 08:21    [W:0.113 / U:1.276 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site