lkml.org 
[lkml]   [2014]   [Mar]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[GIT PULL] PCI updates for v3.14
Hi Linus,

This is a fix for an AGP regression exposed by e501b3d87f00 ("agp: Support
64-bit APBASE"), which we merged in v3.14-rc1. We've warned about the
conflict between the GART and PCI resources and cleared out the PCI
resource for a long time, but after e501b3d87f00, we still *use* that
cleared-out PCI resource. I think the GART resource is incorrect, so this
patch removes it.


The following changes since commit ac93ac7403493f8707b7734de9f40d5cb5db9045:

PCI: Don't check resource_size() in pci_bus_alloc_resource() (2014-03-12 11:19:20 -0600)

are available in the git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/helgaas/pci.git tags/pci-v3.14-fixes-3

for you to fetch changes up to 707d4eefbdb31f8e588277157056b0ce637d6c68:

Revert "[PATCH] Insert GART region into resource map" (2014-03-18 14:26:12 -0600)

----------------------------------------------------------------
PCI updates for v3.14:

Resource management
- Revert "Insert GART region into resource map"

----------------------------------------------------------------
Bjorn Helgaas (1):
Revert "[PATCH] Insert GART region into resource map"

arch/x86/kernel/aperture_64.c | 20 +-------------------
1 file changed, 1 insertion(+), 19 deletions(-)


\
 
 \ /
  Last update: 2014-03-19 19:01    [W:0.024 / U:6.984 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site