lkml.org 
[lkml]   [2013]   [Feb]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 0/3] mm: rename confusing function names
On Wed, 06 Feb 2013 09:06:05 +0800
Zhang Yanfei <zhangyanfei@cn.fujitsu.com> wrote:

> So could I rename the functions to the names like
> nr_available_buffer_high_pages
> And accurately document them with code comments just as you suggested.

gee. "available" implies "available for you to allocate". It has the
same problem as "free".

And "buffer" shouldn't be there - that's a reflection of the fact
that buffer_head payloads are not allocated from highmem. An archaic
irrelevant thing.

Seriously, first let's write down the descriptions of what these
functions *do*. Then choose nice names which abbreviate that.



hm,

static unsigned int nr_free_zone_pages(int offset)
{
...
unsigned int sum = 0;
...
return sum;
}

How long will it be until these things start exploding from
sums-of-zones which exceed 16TB?


\
 
 \ /
  Last update: 2013-02-06 03:01    [W:0.130 / U:1.176 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site