lkml.org 
[lkml]   [2013]   [Feb]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[PATCH 0/3] mm: rename confusing function names
Function nr_free_zone_pages, nr_free_buffer_pages and nr_free_pagecache_pages
are horribly badly named, they count present_pages - pages_high within zones
instead of free pages, so why not rename them to reasonable names, not cofusing
people.

patch2 and patch3 are based on patch1. So please apply patch1 first.

Zhang Yanfei (3):
mm: rename nr_free_zone_pages to nr_free_zone_high_pages
mm: rename nr_free_buffer_pages to nr_free_buffer_high_pages
mm: rename nr_free_pagecache_pages to nr_free_pagecache_high_pages

arch/ia64/mm/contig.c | 3 ++-
arch/ia64/mm/discontig.c | 3 ++-
drivers/mmc/card/mmc_test.c | 4 ++--
fs/buffer.c | 2 +-
fs/nfsd/nfs4state.c | 2 +-
fs/nfsd/nfssvc.c | 2 +-
include/linux/swap.h | 4 ++--
mm/huge_memory.c | 2 +-
mm/memory_hotplug.c | 4 ++--
mm/page-writeback.c | 2 +-
mm/page_alloc.c | 22 ++++++++++++----------
net/9p/trans_virtio.c | 2 +-
net/ipv4/tcp.c | 4 ++--
net/ipv4/udp.c | 2 +-
net/netfilter/ipvs/ip_vs_ctl.c | 2 +-
net/sctp/protocol.c | 2 +-
16 files changed, 33 insertions(+), 29 deletions(-)


\
 
 \ /
  Last update: 2013-02-05 19:01    [W:0.078 / U:0.920 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site