lkml.org 
[lkml]   [2012]   [Jul]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [RFC PATCH 06/13] driver core: firmware loader: always let firmware_buf own the pages buffer
On Wed, Jul 25, 2012 at 01:00:06AM +0800, Ming Lei wrote:
> @@ -750,6 +835,7 @@ request_firmware_nowait(

while you're here, can you fix the arg alignment of this
request_firmware_nowait - it looks awful right now:

int
request_firmware_nowait(
struct module *module, bool uevent,
const char *name, struct device *device, gfp_t gfp, void *context,
void (*cont)(const struct firmware *fw, void *context))
{

and it could like, say, this:

int request_firmware_nowait(struct module *module, bool uevent, const char *name,
struct device *device, gfp_t gfp, void *context,
void (*cont)(const struct firmware *fw, void *context))
{

or something even more readable.

> static int __init firmware_class_init(void)
> {
> + fw_cache_init();
> return class_register(&firmware_class);
> }
>
> diff --git a/include/linux/firmware.h b/include/linux/firmware.h
> index 1e7c011..e85b771 100644
> --- a/include/linux/firmware.h
> +++ b/include/linux/firmware.h
> @@ -12,6 +12,9 @@ struct firmware {
> size_t size;
> const u8 *data;
> struct page **pages;
> +
> + /* firmware loader private fields */
> + void *priv;
> };
>
> struct module;

Thanks.

--
Regards/Gruss,
Boris.

Advanced Micro Devices GmbH
Einsteinring 24, 85609 Dornach
GM: Alberto Bozzo
Reg: Dornach, Landkreis Muenchen
HRB Nr. 43632 WEEE Registernr: 129 19551

\
 
 \ /
  Last update: 2012-07-25 18:41    [W:0.378 / U:0.436 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site