lkml.org 
[lkml]   [2012]   [May]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: [bug?] Battery notifications produce flashing battery icon, syslog spam (Re: [PATCH 11/11] ACPI / Battery: Update information on info notification and resume)
    Date
    Hi,

    in addition to the constant flickering when running on AC, there is a more
    "high frequency" flickering immediately after plugging in the AC: For some 5
    to 10 seconds, the battery appears and disappears (according to upower) around
    once per second. There's also a short moment without battery after plugging
    out the AC.
    All this is gone after going to a kernel version without this patch applied.

    I did not notice unusual high CPU usage of upower on my system, however I
    noticed disc activity - according to iotop, upower is writing several MiB of
    data per minute to /var/lib/upower/ where it keeps some battery statistics. I
    do not know whether this is out of the ordinary.

    Kind regards,
    Ralf


    On Tuesday 01 May 2012 21:14:08 Jonathan Nieder wrote:
    > (cc-ing Andy)
    >
    > Adrian Fita wrote:
    > > Also, searching on Google after "upowerd device
    > > removed:/org/freedesktop/UPower/devices/battery_BAT0", reveals much
    > > more bug reports with the exact issue.
    >
    > Thanks. That confirms the high CPU consumption in upowerd ---
    > see [1], for example.
    >
    > [1] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/987807


    \
     
     \ /
      Last update: 2012-05-01 22:01    [W:0.024 / U:31.308 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site