lkml.org 
[lkml]   [2012]   [Feb]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: GRUB doesn't like ServeRAID M1015/LSI 9220-8i (was Re: mvsas with 3.1)
    On 01/02/2012 15:16, Hannes Reinecke wrote:
    > On 02/01/2012 03:42 PM, Thomas Fjellstrom wrote:
    >> On Wed Feb 1, 2012, John Robinson wrote:
    >>> On 01/02/2012 14:03, Thomas Fjellstrom wrote:
    >>> [...]
    >>>> I picked up a refurb IBM
    >>>> ServeRaid M1015 (aka: LSI 9220-8i) card. It arrived yesterday. Just have
    >>>> to wait and see why grub doesn't like it.
    >>>
    >>> When you find out, please let me know - I bought one via ebay, its
    >>> firmware was elderly and wouldn't let me put it in JBOD mode, after a
    >>> bit of googling I flashed it with IBM's latest firmware, then GRUB
    >>> thought my machine had no RAM in it.
    [...]
    >
    > From my experience the BIOS wouldn't present any disks in JBOD mode.
    > So you'd be needing to switch to RAID mode first.

    The firmware my card came with didn't have a JBOD mode, which is why I
    flashed the newer firmware. Then I could boot in JBOD mode from a rescue
    CD and see some drives, though not those that had had RAID-mode metadata
    written to them, but I couldn't boot the system with GRUB (from drives
    on another controller).

    Cheers,

    John.


    \
     
     \ /
      Last update: 2012-02-01 16:29    [W:0.022 / U:64.276 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site